-
1Step 1
For each router, download the OpenWRT image from downloads.openwrt.org, log into the router, and upload as a firmware update. The router is now running OpenWRT.
-
2Step 2
Next, log in over telnet (telnet 192.168.1.1) after getting an IP, and set a root password using passwd.
-
3Step 3
Log back out, and log in using SSH, using the password just set.
-
4Step 4
Edit /etc/config/wireless, and replace the config wifi-iface block with:
config wifi-iface
option encryption 'none'
option device 'radio0'
option mode 'mesh'
option mesh_id 'mesh'
option network 'mesh' -
5Step 5
Use the UCI tool to bring up the wireless interface (uci set wireless.radio0.disabled=0; uci commit wireless; wifi)
-
6Step 6
Repeat the above steps for the other 2 routers.
-
7Step 7
For router #1, add a new interface to /etc/config/network, named 'mesh':
config interface 'mesh'
option ifname 'wlan0'
option proto 'static'
option ipaddr '10.0.0.1'
option netmask '255.0.0.0'
option ip6assign '60' -
8Step 8
Also in router #1, edit /etc/config/dhcp, to allow DHCP leases on the new interface:
config dhcp 'mesh'
option interface 'mesh'
option start '2'
option limit 16777213
option leasetime '24h'
option dhcpv6 'server'
option ra 'server' -
9Step 9
In routers #2 and #3, add an interface to /etc/config/network, but this time, change it to this:
config interface 'mesh'
option ifname 'wlan0'
option proto 'dhcp' -
10Step 10
Also in routers #2 and #3, add a DHCP ignore rule:
config dhcp 'mesh'
option interface 'mesh'
option ignore '1'
Discussions
Become a Hackaday.io Member
Create an account to leave a comment. Already have an account? Log In.